Talk:How To Flash the WRT54Gv8

From DD-WRT Wiki

Jump to: navigation, search

Hi all.

I have a WRT54GV8 (serial: CDFG1G8F1151) and I tried to flash the router, but no sucess.

I do reset (unplug power, push reset, plug in power, wait 30 sec) and I see the management screen.

I select the image vxworkskillerGv8-v3.bin and select Apply. I wait, wait, wait and nothing happens, except that the router returns to the IP that I configured. Note that when I do reset the router goes to the address.

After that, and doing or not doing the recycle, when I try to tftp the ddrt image to it it gives me Error 2: Access Violation.

I reset the router and everything is as always.... Linksys firmware, but, of course, without configuration.

I followed the page.

Any thoughts?



20 June, 2008

I've had the same issue, having followed How To Flash the WRT54Gv8. The router appears to still be listening on tcp/8080 (hitting it from the LAN side, wired), but it seems to want to give me an SSL certificate that Firefox says is a duplicate. Additionally, it still appears to pass traffic (i.e., act like a firewall). Have I brickified my router/AP? Anyone have any ideas?



UPDATE 20 June, 2008:

I was able to recover using the Recover from a Bad Flash article (thanks, DD-WRT community!), using only the directions at the top of the page (i.e., didn't have to engage in the Linksys/WRT-specific stuff). Apparently, my downfall was the use of Firefox (MacOS X 10.5.3, FF After recovering the default Linksys firmware, I tried the How To Flash the WRT54Gv8 instructions again using Safari, and everything went as described.



[edit] RE: Flashing via TFTP

I tried to follow the instructions regarding flashing from a MacOS platform, and got no where. I did a little research, and a free TFTP client did the trick. It was incredibly easy. simply enter the IP address of the router, select the firmware to flash, and click start. The shareware (nag screen before use) is called MacTFTP and can be found at For other OS's, just do a google search. (ie Windows TFTP client) It worked great for me, I'm running the dd-wrt firmware without any problems and was able to extend my wireless signal from the house to the church, approximately a 75 meter run.

[edit] what now

i was doing the upgrade. went to the linksys firmware upgrade button and installed the works killer bin. then i tried to install the ddwrt upgrade buuuuuut, it didnt work. i realized that i need a tftp software to do this part. does anyone of any good programs that i can use and step by step procedures of doing so? kind of new at this. thanks.


[edit] RC5 to RC6.2

Hi! I flashed my WRT54Gv8 using this page

The firmware I used is the one on the page (RC5), but after the successful flash, I read that the latest version is 6.2

In the RC5, when I connect via telnet, the prompt looks bad, it doesn't get the "\u" and "\h" so the prompt is:

\u \: \h \$

Also, I don't have "ls"

Where can I get the 6.2 version? How to flash it? Do I have to revert to original firmware and then reflash it to 6.2?

Thanks in advance!

[edit] Firmware v8.0 and v8.2

I tried to change the firmware to the dd-wrt usinig what was said but, after changing it, I couldn't connect to internet. So I tried to return to the original firmware. As was said: "Use the firmware upgrade dialog to flash your original linksys firmware WRT54Gv8_v8.00.0_fw.bin. When the upgrade success screen comes up wait 2 minutes. " I thought that it was the firmware just for the v8.0. So, I tried the website of the linksys and downloaded the firmware that, in the site, was classified as the firmware "8.2.05 - 1/18/2008. The problem: after I did what was said to return to the original firmware, and installed this firmware, in my router setup, it is "Firmware Version: v8.00.5 build 002, Jan. 9, 2008".

Ok:Do they (v8.0 and v.8.2) use the same firmware, or the site is wrong?

Thank's a lot.

[edit] Http/Https?

Does it matter if I only allow https connections @: /Administration/Management/Access Server?