Talk:How To Flash the WRT54GS v7

From DD-WRT Wiki

Jump to: navigation, search


[edit] v7.5(Firmware) Flash Not In The Wiki?

I have a WRT54GS v7(sticker underneath) But when I look in the webui it says it's v7.5 .What version if any at the present moment would I be using of the killer/v24 micro? I'm sorry, But I haven't been able to get any response from anyone on freenode(#dd-wrt & ##dd-wrt). I don't want to brick my friends overpriced wrt54gs. Thanks. JoelWells

[edit] Brick

Erik: When I tried this, it bricked my WRT54GS v7 completely. to the point that when you plugged something into an ethernet port, it was not recognised by the computer, even with a static setup.

[edit] Another Brick

Whidbeycs - I guess you can add mine to the pile. The same thing happened to mine. Port lights and Internet light are steady on. All other lights are off.

[edit] Maybe we should..

..change the name of this article to "How To Brick The WRT54GS V7"

I will remove these instructions from the supported devices page. Don't know what is going on here...

[edit] no longer a Brick

Whidbeycs - With nothing left to lose, i recycled the power while holding down the reset button (for 20 sec). Now its working. One less brick.

[edit] another bricked router

Well i just bought this router today and its bricked tried the flash and all that i see is the solid internet light and the port light all other lights are out tried the pwr cycle with the reset didnt work

[edit] Re: how to flash WRT54GS V7

another brick... anyway to unbrick?

[edit] eureka!

bricked after it kept timing out on dl the fw... figured it out... unplug everything from the back of the router open cmd prompt, "ping -t" you'll get another timed out response or similar, just keep the window open and let it continue to run now, hold the reset button in on the back of the router, plug in the ethernet cable keep the button held in now plug the power cable back in keep the button held in for another 30 seconds or more let the reset button go, and you should start pinging the router successfully by now open another cmd prompt where your tftp and fw are and and again attempt to load the fw, should say success should take a min or so and reset successfully go to and you're on your way!

I found this fix at

[edit] Strange Behavior

I followed the instructions contained in "Another similar method to flash WRT54G v8 and WRT54GS v7.2 (possibly other 7.x)" and have the following problem with my WRT54GS v7.2. The power light cycles on an off slowly. At one time it seemed to send the letters A and V in Morse Code. When I plug in the cat 5 cable into any of the 4 ports, the light comes up. I tried all the resets to no avail. I am able though, to ping but when I attempt to tftp the factory bin, I get a message that the request timed out. I seem to have two reset switches, one in the back and the other in the front to the left of the power led. I have 3 ic's, a Broadcom, a Samsung and an Eon. At this stage, all I need is to get it to work in factory condition. Thanks for any help. This is my first attempt with a router.