DD-WRT Wiki talk:Community Portal

From DD-WRT Wiki

Jump to: navigation, search


I have a linksys wrt54gl V1.1 and I have updated it to V24sp1. Since the update the router does not broadcast like it did before. Can someone tell me where to look to find the setup page to make the wifi work. Thanks BERNIE


[edit] ========================================================

December 23, 2007 User: UnraisedArc20 Content: Hello. I am trying to flash DD-WRT firmware onto my fonera router, but the firmware version is 7.2 r2. I have tried the reset button hack but it did not work. My router is about a year old, so the original firmware is 7.1 r1 I believe. How do I get back to this firmware? Thanks, Unraised

[edit] Bridge mode available for WRT300N (Linksys)?

I'm wanting to set up a bridged network using a Linksys WRT300N. I've done it using a WRT54G but before I buy the WRT300N I wondered if anyone has done this or if the bridge mode is even available for this router. Thanks. -Kapuna

P.S. The reason I want to use the WRT300N is for the extended range of the 802.11n protocol. Does the current flash (or RC or beta) support this protocol? Thanks -Kapuna (2/2/08)

[edit] have a fonera 2100 with v24 RC6.2 and is not working in router anymore

practicaly it doesen't do what it was ment to do, i mean to be a wireless router when you use the ethernet port for internet and connect wireless devices to the wlan the router can obtain ip/netmask/dns as wan and the wireless devices connected to him recieve ip from class, and i can ping sites in the internet. but i can not open webpages, connect to messenger...nothing...am i doing something wrong?

[edit] wrt54G debrik procedure with jtag cable .... help me

Hello people

I have briked my wrt54g v.5 during the upgrade with dd-wrt firmware (the power led blinking, the reste procedure don't work, no managment page http)

I tried whit jtag cable and hairdairy... 4.8 but I' dont know the file to flash ex. cfe.bin I have create with (imgtool_nvram.exe) kernel.bin I have used (03_dd-wrt.v24_micro_generic.bin)

but the router don't work :-(

it's possible to have the sequences of file to flash cfe.bin = ???? nvram.bin = ????? kernel.bin = ????? wholeflash.bin = ?????

for the latest stable dd-wrt and is possible the original file for the linksys in the linksys site is possible to download only firmaware that i think is the kernel.bin ?

Thanks a lot

for your precious support


[edit] Bridging a Linksys WRT150N to a Linksys WRT300N

I mistakenly bought the Linksys gear thinking I could configure them to connect to each other via their wireless interfaces. Then I discovered both devices only operate as Access-points with Linksys firmware.

Using dd-wrt I was able to get the Linksys WRT150N v1.1 to associate with my Linksys WRT300N v1.1 in Client Bridge mode. I can now connect hosts that don't support wireless adapters to my home network.

I followed the instructions under the Wireless Bridge page. I first flashed the 150N with dd-wrt.v24_mini_generic.bin followed by dd-wrt.v24_std_generic.bin.

I set mode to N-only on both the 150N & 300N. The 150N's IP address is which I set manually. I am using WPA2-Personal, AES encryption and a pass-phrase.

Thank you dd-wrt team!!

[edit] Netgear WGR614

I'm thinking of getting one of these to use as a wireless repeater since they seem to be pretty cheap used (eg comp to linksys). I'm lookin at a couple for sale that are version 7 but your compatibility table only lists version 8. would a V7 or other earlier versions take dd-wrt? Also, would this router be any good as a repeater?

[edit] WRT54G vs. WRT54GL

WRT54G v2.2 vs. WRT54GL v4.30.5


I flashed my WRT54G with dd-wrt.v23_mini_wrt54g, and accessed the web interface using “root” as the user name and “admin” as the password. This process worked fine. Then I flashed the router again, this time with dd-wrt.v24_mini_generic. Now I can’t get into the router. I have tried using with “root” and “admin” in a few different combinations. I want to get in to flash it again with dd-wrt.v24_std_generic for the last time. I think this is what I need to do…

Also, my Linksys router indicates that it is a WRT54G v2.2 on the bottom of it, but the inside interface original firmware indicates that it is a WRT54GL v4.30.5, Which one should I believe and which directions should I follow to convert it to a repeater or bridge?

Thanks-a-ton for your help!


[edit] WRT54G3G and GT MAX with a new firmware


I've just bought a WRT54G3G router and used with an Option GT MAX 7.2 card from T-Mobile. It has been OK for today when I had to change the firmware of the card to a new one. Firmware version: 2.5.11Hd (Date: Feb 11 2008, Time: 15:10:46)

Until the time of firmware change the router doesn't find the card.

Can you help me if there is a version of DD-WRT which solve this problem?

Thank you in advance,

- amma

[edit] Setting up WRT54G as Access Point with one Broadcast Domain

I have a cisco 2600 as my main router and I am adding a WRT54G (v5 running DD-WRT Generic) to the network via a cisco 2924 switch. I need the entire network to maintain one broadcast domain for apple's Bonjour protocall to work properly. I have the WRT54G setup with DHCP off, mode="router" and connected via port #4 to my switch. This works to provide internet connectivity to my wireless computers but it seems to segment broadcast domains. I have clicked "LAN Uplink Through WAN Port" as I believe this is supposed to make the WRT54G act like a layer 2 switch. But it does not seem to work.

Am I missing something? Please help.

[edit] Advice please: wireless bridge or repeater


I am setting up wireless connection in my house and need some help...is repeater same functionality as bridge?


I have a wireless router on second floor and that setup works fine....I want to setup a similar setup in the ground floor and share it with basement, but unfortunately I can't run Cat6 from second floor to ground level. So I am thinking should I get a second router, install it on ground floor and use it in "client" mode only? or should I setup to repeat the first router?? I would like to computers connected to this second router be able to access computers on first router for sharing etc...


[edit] Adding Netgear router as wireless

I have a Linksys wireless router that I am using as a switch only - I have the radio turned off. I have a Netgear WNR834B v2 that I am using as the wireless source.... it comes off of the back of the Linksys and everything works fine. My problem is that I can only access the Linksys remotely - I cannot see the Netgear. Any idea on how to make the remote access work on the Netgear? I'm a newbie, so please spell it out in easy-to-understand terms.


[edit] where is /tmp/.ipt created from?

Greetings all --

Here is the deal - i created a PPTP connection to my dd-wrt router in the states.. Using the GUI I created a rule for forwarding a bunch of ports (1024:65535) to a Linux box for bind. Well now I can't make a PPTP connection since PPTP uses a port within this range.

So fortunately, I am able to ssh into the linux box (since previously I setup a port forward for ssh). From here I am able to telnet into the router.

I first go to /tmp/.ipt and delete the lines that contact this port forward for the range of ports - reboot the router and find out that this file gets created at boot time. Ok.

So my question is -- from what file does this get created from? What file can I edit to remove these port forwards? I snooped everywhere and could not find this file - only a nvram file which is a binary file which looks to me where this information is stored - but I could be wrong. this is my first time snooping in dd-wrt

Next question, using iptables I remove the fowards -- and verify they are removed but I still can not get a pptp connection even with these (1024:65535) forwards removed. why??

thanks so much


[edit] Limit Downloads by size/MAC

Hi All,

I just discovered this tool and man that looks great to me. I have just a question I haven't been able to find the answer for yet. My internet connection is limited on downloads size and I need to share it with other people. I'd like to limit the size of the downloads for every computer on the network but mine. So basically, if the download is more than XX Kb, I want to block it. I saw we can easily limit the bandwidth but haven't found something for limiting the size of the downloads. Is that something possible?

Cheers, Jerome

[edit] Connex Wireless Q-Bridge Plus and DD-WRT

Hey everyone! DD-WRT is the best.

I was wondering if anyone knew, or knows how to find out if DD-WRT will work on the Connex Wireless Q-Bridge Plus router/bridge. They can link up to 4 miles with line of sight, and are fairly expensive so I'd like to avoid bricking them. That being said connex's firmware is lacking in many areas. I'd like to run some apps from a network share to do some ethical hacking among other things. The most frustrating thing is that the device(s) run an SSh server, but there is no password supplied that works on it!

Any insight would be greatly appreciated. The Manufacturer of the Q-Bridge is Connex Wireless. [1]

Happy belated thanksgiving!

[edit] Best Router to start with?


I was a big fan of DD-WRT, but made the mistake of buying a Linksys WRT54gs v5 the last time I needed a new router. I know the micro version will work with this, but I never bothered with it.

My V5 recently died so I'm in the market for a new router. I'd like to buy something with the best mix of relaibility, features, full support for custom firmware. Any suggestions? I realize this is somewhat of a subjective question, but feedback would still be greatly appreciated.



[edit] Setting up Dual Access (LAN + PPPoE) on a Linksys WRT54GL with Dynamic IP on WAN.

How? ISP's LAN has an FTP and a DC-servers inside. When disconnected from PPPoE WAN has an IP from ISP's LAN and can use local servers, but since connected to PPPoE WAN has another IP and lacks access to local resources. Static route cannot help as there's no static IP for my WAN port. How can I set up iptables to get dynamic IP from WAN to create static routes?

[edit] Compatible routers & Question about DIR300?

Hi Group,

I have a few devices that I cannot seem to find info on:

Linksys WRTP54G (2 VoIP ports included)

TP-Link WA601G Access Point

TP-Link TL-WR641G/642G

Can anyone tell me if these are compatible?

I just flashed my Dlink DIR-300 and and very pleased with the amount of customization there is... now I just need to read the WIKI on what everything does:-)

I wanted to set up the DIR300 as a repeater but I don't have this option in the wireless mode dropdown, can someone help/explain?



[edit] Access restriction policy

Hi everyone,

I've been reading through the pages trying to find the right instrument or my router to restrict internet access for my son to stop him playing an internet game after a specitied time each day.

What I am missing in all these access rules (policies) is a kind of clock, that starts running the moment that a certain IP adress starts to communicate with a certain internet address, and after a time (that can be preset in the policy) has elapst, a certain rule will be be enfoced/become effective.

I am sure this is a desireable feature for millions of mothers and dad's and for all of you bit-wise man I'am sure it can't be that difficult to solve.

We will all love you for that!!!


[edit] time stamp values genrated on linksys wap54g with dd-wrt firmware on

Hi every one

can any one please help me!!!

i have captured the beacon frame packets on linksys wap54g having dd-wrt firmware on it

here when i look into the timestamp values in the beacon frame the right first value start with 102789microseconds next are 205189,307589,409989etc... so the beacon interval maintained is 102ms i hope its behaviour is good.

what i want to know is how these timestamp values are generated from that particular value(102789) all the time to make sure i have captured more than 10 times.

to see the differnce i have capture the beacon packets on linksy AP WAP54G firmware one where the timestamps values are not the same values but hey are slightly near to these values like 102790,102792,102794 these are the right first values which changes all the time of the capture.

so here can we know about this timestamp value generation on AP. i know some information that a clock inside the AP will generate these values at time where beacon frame generates from it is that right?

my questions are how does the timestamp value generated exactly 102789 all the time on dd-wrt AP? is there any algorithm in it or depends on physical component or is it a hardware ???????????????

thanks vamshi

[edit] security DD-WRT repeater

Noob user looking for advice. I have my Linksys WAP54G flashed with DD-WRT and configured as a repeater along these guidelines: http://airfart.blogspot.com/2008/03/how-to-set-up-wifi-repeater-mode-on-dd.html

I am using it to improve my reception for local WiFi internet service.

How do I configure the repeater so that my computer is the only one that can use it? Thx for any help.

EDIT: Never mind! discovered this: http://forums.whirlpool.net.au/forum-replies.cfm?t=890888

[edit] Configure DD-WRT as a repeater to access GoogleWiFiSecure?

Is it possible to configure DD-WRT as a REPEATER to access GoogleWiFiSecure?

How to access GoogleWiFiSecure directly:

"create a new network connections profile with the following settings:

SSID: GoogleWiFiSecure (case-sensitive)

WPA/WPA2 Settings


Encryption method: AES (preferred) or TKIP

Authentication Protocol: MS-CHAP-V2 or CHAP

Trusted Server Name for Authentication: onex.wifi.google.com

Under the 802.1x settings be sure to enter the username and password that you obtained earlier."

From: http://www.google.com/support/wifi/bin/answer.py?answer=65601&topic=11363

Linksys WAP54G; currently enabled as repeater for GoogleWiFi (unsecured) according to these settings:


Windows XP

Thanks for any help.

[edit] Cannot flash Netgear WNDR3300

I'm having trouble flashing this router. Using the Netgear GUI I used the preflash file specific for this router, std-wndr3300.chk. When finished I hard reset the router using 30/30/30. Once the router comes back up the power light is flashing. It is pingable but no gui at I then flashed using the mini_generic.bin using tftp. Once again, hard reset and power light flashing, no gui but pingable.

Any suggestions would be appreciated.


[edit] Belkin F5D8230-4

I'm trying to bridge this Belkin router (F5D8230-4) to my Linksys WRT610N. The compatibility table for the Belkin has some comments about the chips. Can you please provide more explanation about what I need to do in order to get this to work? Do I need to physically swamp the chips?

[edit] WAP54G v3 LAN (802.1q) Question...

Hi everyone,

I was trying to setup VLANs on the WAP54G but got locked out a few times and can't seem to get it working. I setup VLANs with other APs like MiktoTik. Or ther firewall / swithces, I seem to have some problems with DD-WRT.

This is the setup I want to get:

WAP54G will have two SSIDs SSID1-Corporate SSID2-Guests

The eth port will be a trunk port hooked to a 802.1q trunk port managed swith. (AP has only one eth port)

All I want to do is the following:

Bridge SSID1 - to VLAN ID: 1 (untagged - PVID1) Bridge SSID2 - to VLAN ID:50 (tagged)

I don't need any firewall or router/nat on the AP just bridge the SSID to a specific VLAN.

Can you one give me a few hints ?



email: jjackowski {at} gmail.com

[edit] Problem mit Netgear WG602

Hallo Habe auf meinen Netgear WG602V3 DD-WRT eingespielt! Will jetzt aber wieder die Original FW 1.2.5 aufspielen, bekomm es aber nicht hin! Kann mir jemand helfen?

Mailto: Schneider-Gonzertath@web.de Danke

I am really thankful yo you for giving me such a nice platform during my browsing. Actually i want to migrate USA for job purposes and i want to search before my departure. But right now i am busy in my [mcse] and just after it i will be researching thoroughly. Once again thanks. mcse

[edit] Cann't get IP with DNSMasq as DHCP server on engenius EOC 2610

I set my Engenius EOC 2610 with 2 SSID, SSIDA n SSIDB, and i use DNSMasq as DHCP server, at SSIDA it's OK, I get an IPAddress, but at SSIDB itsn't get IPAddress. SSIDB use virtual wireless (ath0.1) What's the right command in DNSMasq, which can solve my problem? Thanks...

[edit] Isolate WLAN + 1 LAN port and the rest of LAN ports + WAN

Hello all ! I'm diging into this topic since quite a few weeks now. Configuration : 1 Cable Modem for internet access 1 Linksys WRT54G v5.1, 4 ports + WAN + WLAN 1 Astaro GW : Security GW with 2 NICs

I'm trying to do the following : Wifi Client are routed to the Astaro GW for Proxying, P2P filtering, IM filtering and then redirected to internet. I thus need to isolate the WLAN with one LAN port (connected to the firs NIC of my Security GW). The second Nic of the GW will be connected to another LAN port and gain access to internet.

WIFI must not have direct access through linksys router.

I was able to isolate WLAN and LAN, leaving them both access internet separately. But never been able to create a VLAN including WLAN and port 1 for exemple, with no access to internet, and then a second VLAN with port 2,3,4, connected to internet directly.

Any Idea ? Help ? thanx a lot, i know that's not common or interesting but if you've got any idea or explanation on how it could work. Actually i did not really understood the internal schematics of the Linksys (except from Gary Court Schemas).

Again thanx and have a nice day

[edit] WRT54G/GL 'How To' has installation errors

This 'how to' has many errors when using a WRT54GL; http://www.dd-wrt.com/wiki/index.php/WRT54G_v4_Installation_Tutorial

1. The very 1st link is dead.

2. The 1st step is outdated and doesn't apply to the GL version. It points you to a older V23 'package'.

3. According to the "Peacock" thread, a 30-30-30 hard reset is needed before you flash the router.

4. It tells you to reset to factory defaults using the web interface, than hold the reset button for 30 seconds which does the same thing and clears the memory. So does the 30-30-30 routine that isn't mentioned.

5. Step four only tells you to hold the reset button again for 30 seconds, not the recommended 30-30-30 routine.


Wondering whether the WGR614 v7 router by NETGEAR is compatible. Please send me a response at serosian@hotmail.com if you know the answer whether it is yes or no. Thanks.

[edit] Signal Strength meter for wired router

I have attached a dish antenna to my WRT54G (as accesspoint) with DD-WRT. I know about netstumbler but it only works with wireless cards. How do I aim the dish without a field strength meter such as netstumbler since the computer thinks that I have a direct connection? Any Ideas? I know that you guys have done this many times but hey, I'm a new guy. Thanks in advance.

I installed DD-wrt on my wrt54g v6 easily, everything went well, i changed the username and password, internet works fine. But i cant change the other settings, when i press save or apply, it bring a white page (apply.cgi) and the setting doesnt stay. Any idea ?

[edit] U-Verse and wirelessly bridged WRT300N. Can't connect with WEP-Open on.

I have a flawless connection when security on the Uverse router is disabled, but this isn't going to fly. Does anyone know of a successful setup with a different type of security (or perhaps I'm missing a setting with WEP-open?) Thanks.

[edit] Do I have a problem or is this normal? WAP45g

Hi all,

I'm new to the site, and so far I love all of the material here.

I just recently upgraded a linksys WAP45g to the DD-WRT firmware and it is working great! I set it up using the instructions on the "Wireless Access Point" how to on this wiki as it is on a larger network with a Linksys RV082 router that is handling the DHCP.

Question: When I log onto the WAP45g's management through firefox, and look at the status, under the "Network" box at the very bottom, my "Active IP Connections" is bouncing between 35 and 45, but i'm the only one connected to the access point. Is this normal or is there an issue? Here is link to the screen shot of the active IP addresses.




[edit] help needed with client router

Hi i am having a problem..i am not getting a ip address on my wrh54g linksys router..i flashed it with the dd-wrt firmware..i m using this as a client device..for my xbox 360 to be able to play wireless on xboxlive..my main router is a dlink dir-300..i have followed the steps on the wiki..and did everything like what was said there i m still unable to get this work..the guide i followed was this http://www.dd-wrt.com/wiki/index.php/Client_Mode_Wireless

can any 1 hlep me to get this working..and tell me where i may have gone wrong..